Did you know? 4 depends on mozjs (via polkit), Rust (via mozjs, librsvg, etc.), and Qt (via GStreamer)!

issues.guix.gnu.org/51994 👈

@civodul How does GStreamer depend on Qt...? QtMultimedia is now using GStreamer...????

Follow

@be Via gst-plugins-bad actually:

$ guix graph --path gtk qtbase@5
gtk@4.2.1
gst-plugins-bad@1.18.5
libde265@1.0.8
qtbase@5.15.2

@be @civodul Why indeed… qt in gst-plugins-bad seems like a legacy thing, the Qt plugins are in -good for 1.18.x and it's something that you could split into another package.
Sign in to participate in the conversation
Mastodon (Aquilepouet)

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!